Back to overview
Resolved

Delayed push notifications and degraded performance

Jun 25, 2026 at 4:00pm UTC
Affected services
Ziber Kwieb 4
Ziber Kwieb 5

Resolved
Jun 25, 2026 at 6:00pm UTC

The job queue backlog has fully cleared. Push notifications and app performance have returned to normal. All delayed notifications have been delivered. We are reviewing measures to prevent recurrence.

Updated
Jun 25, 2026 at 4:20pm UTC

We have identified the cause: a backlog building up in our background job queue due to a spike in demand. Push notifications are being delivered with a delay. No messages are being lost.

Updated
Jun 25, 2026 at 4:15pm UTC

We are investigating reports of delayed push notifications and degraded app performance in Kwieb. We are actively monitoring the situation.

Created
Jun 25, 2026 at 4:00pm UTC

Users may experience delayed push notifications and slower than normal app performance. We are investigating the issue.